Thunderbird 60.5.0 released

[German]Mozilla’s developers have released the email client Thunderbird version 60.5.0. This is a maintenance update which fixes some bugs and some critical vulnerability. An update is recommended as soon as possible. Here is some information about it.


Advertising

German blog reader Ralf pointed out the new release in this comment (thanks for that). I just started the update search in Thunderbird, and got the update offered.

Thunderbird 60.5.0

According to the release notes some new features have been introduced and a number of minor bugs have been fixed – here is the list of new features:

  • FileLink provider WeTransfer to upload large attachments added
  • Thunderbird now allows the addition of OpenSearch search engines from a local XML file using a minimal user inferface: [+] button to select a file an add, [-] to remove.
  • More search engines: Google and DuckDuckGo available by default in some locales.
  • During account creation, Thunderbird will now detect servers using the Microsoft Exchange protocol. It will offer the installation of a 3rd party add-on (Owl) which supports that protocol.

And here ist a liste of fixes in the new Thunderbird version:

  • Thunderbird now compatible with other WebExtension-based FileLink add-ons like the Dropbox add-on
  • Crash when using custom sound for new email notification fixed

In addition, Thunderbird 60.5.0 fixes a number of security issues. Some of these vulnerabilities are considered critical, so the email client needs to be updated as soon as possible. In the new Thunderbird version, however, there are some known issues:


Advertising

  • Due to changes in the Mozilla platform profiles stored on Windows network shares addressed via drive letters are now addressed via UNC.
  • CalDav access to some servers not working. Workaround: Set preference network.cookie.same-site.enabled to false.
  • Chat: Twitter not working due to API changes at Twitter.com.

The e-mail-client is available for Windows 7, Windows Server 2008 R2 or higher – Mac: Mac OS X 10.9 or higher – Linux: GTK+ 3.4 or higher. The system requirements can be read here. The download is possible via this website.


Advertising


This entry was posted in Software, Update and tagged . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *